Project Unknown's Blog

Peojct.Unknownと言う名前で細々とアプリ開発をやってるメンバーのブログです。

XCode7.0にしたらpod installが出来なくなった件

ゆう@あんのうんです。

久々にXCodeを触ってcocoapodを使おうと、

pod install

したら、以下の様なエラーが出るようになりました。

$ pod install                                                                                                  [省略]
Analyzing dependencies

CocoaPods 0.39.0.beta.5 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Downloading dependencies
省略
Generating Pods project
2015-10-04 01:50:52.884 ruby[22824:370074] [MT] DVTAssertions: ASSERTION FAILURE in /Library/Caches/com.apple.xbs/Sources/IDEFrameworks/IDEFrameworks-8227/IDEFoundation/Initialization/IDEInitialization.m:590
Details:  Assertion failed: _initializationCompletedSuccessfully
Function: BOOL IDEIsInitializedForUserInteraction()
Thread:   <NSThread: 0x7fe73529c1b0>{number = 1, name = main}
Hints: None
Backtrace:
  0  0x0000000105e20a5c -[DVTAssertionHandler handleFailureInFunction:fileName:lineNumber:assertionSignature:messageFormat:arguments:] (in DVTFoundation)
  1  0x0000000105e201e9 _DVTAssertionHandler (in DVTFoundation)
  2  0x0000000105e20455 _DVTAssertionFailureHandler (in DVTFoundation)
  3  0x0000000105e203b7 _DVTAssertionFailureHandler (in DVTFoundation)
  4  0x0000000107b48f5c IDEIsInitializedForUserInteraction (in IDEFoundation)
  5  0x000000010a748eb9 +[PBXProject projectWithFile:errorHandler:readOnly:] (in DevToolsCore)
  6  0x000000010a74aa3e +[PBXProject projectWithFile:errorHandler:] (in DevToolsCore)
  7  0x00007fff8d686f44 ffi_call_unix64 (in libffi.dylib)

単純にpodのupdateかなーと思い。

$ pod update

でupdateを実施しようとしても同じ事が発生。 どうしようも無いので、本体の方をupdateしてみます。

$ sudo gem update cocoapod
Updating installed gems
Updating cocoapods
Fetching: cocoapods-core-0.38.2.gem (100%)
Successfully installed cocoapods-core-0.38.2
Fetching: claide-0.9.1.gem (100%)
Successfully installed claide-0.9.1
Fetching: xcodeproj-0.26.3.gem (100%)
Successfully installed xcodeproj-0.26.3
Fetching: cocoapods-downloader-0.9.3.gem (100%)
Successfully installed cocoapods-downloader-0.9.3
Fetching: cocoapods-plugins-0.4.2.gem (100%)
Successfully installed cocoapods-plugins-0.4.2
Fetching: cocoapods-stats-0.5.3.gem (100%)
Successfully installed cocoapods-stats-0.5.3
Fetching: cocoapods-try-0.4.5.gem (100%)
Successfully installed cocoapods-try-0.4.5
Fetching: cocoapods-trunk-0.6.4.gem (100%)
Successfully installed cocoapods-trunk-0.6.4
Fetching: molinillo-0.3.1.gem (100%)
Successfully installed molinillo-0.3.1
Fetching: cocoapods-0.38.2.gem (100%)
Successfully installed cocoapods-0.38.2
省略

updateが出来たので、再度

pod install

を実施。

[省略]
Updating local specs repositories

CocoaPods 0.39.0.beta.5 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
Downloading dependencies
省略
Generating Pods project
Integrating client project
Sending stats

問題なくinstallすることが出来るようになりました。